Eclipse Plug-in Help

 

Dynamsoft SourceAnywhere for VSS Eclipse plug-in is a Team provider plug-in for the Eclipse IDE. It enables users to perform Dynamsoft SourceAnywhere for VSS operations from within the Eclipse IDE. This plug in supports Eclipse release 3.x.

Dynamsoft SourceAnywhere for VSS Eclipse plug-in can be used on various operating systems such as Windows, Linux, Solaris , Mac, etc.

Note:

Installation

The installation procedure is as follows:

  1. Start Eclipse IDE. On the Help menu, click Software Updates and choose Find and Install.
  2. In the Feature Updates dialog box, choose "Search for new features to install" option.
  3. In the Update sites to visit dialog, click New Remote Site button. Input a name for this update site (e.g. SAWV Eclipse Plugin) and one of the following URLs (according to the version of SourceAnywhere for VSS you are using):
    [Version 6.2] http://download.dynamsoft.com/eclipseplugin/sawv/
    [Version 6.1] http://download.dynamsoft.com/eclipseplugin/sawv6.1/
    [Version 6.0] http://download.dynamsoft.com/eclipseplugin/sawv6.0/
    [Version 5.4] http://download.dynamsoft.com/eclipseplugin/sawv5.4/
  4. Check the "SAWV Eclipse Plugin" box in the Sites to include in search pane and click Finish.
  5. In the Search Results dialog, choose the features to install and click Next.
  6. Please read the license agreement of Dynamsoft SAW for VSS Feature carefully,  then select "I accept the terms in the license agreement." 
  7. In the Installation dialog, select the Dynamsoft SAW for VSS feature and choose a location to install it. Then Click Finish.
  8. Verify the feature information in the Feature Verification dialog and click Install.
  9. Restart the Eclipse IDE for the changes to take effect.

Or you can download the SourceAnywhere for VSS Eclipse plug-in from the download page of SourceAnywhere for VSS, and on the 3rd step above, click New Archived Site and browse to the SourceAnywhere for VSS Eclipse Plug-in.

How to enable the plug-in

The Dynamsoft SAW for VSS plug-in works on a per Eclipse project basis. Each project in your workspace can be configured separately and can mount a VSS database. If you need to mount more than one VSS database you must use separate Eclipse projects. 

1. Configure a team provider for your project.

Right click an Eclipse project and select Team -> Share Project to bring up the select repository wizard.

2. Select Dynamsoft SAW for VSS as the repository type.


3. Input the server name and port of Dynamsoft SAW for VSS server.

Server

Select or type the Dynamsoft SAW for VSS server IP.

Port

Select or type the Dynamsoft SAW for VSS server port.

Proxy Information

Input the the proxy information (if proxy is used).

4. Login VSS database

User

Type your username.

Password

Type your password.

Database

Choose a VSS database to login.

Encryption Status

Show the status of encryption.

5. Path Mapping

Local

Displays the path to the local workspace of the Eclipse project.

Remote

Type the path of the Eclipse project in the VSS database.

Browse

Click to bring up the Add To SourceSafe project dialog. You can select an existing VSS project or create a new one.

6. Your project is now configured for using the Dynamsoft SAW for VSS Plug-in.

Now if you right click context menu on the project and select Team, you will see some additional Dynamsoft SAW for VSS plug-in functions.

The Dynamsoft SAW for VSS plug-in actions are also available from the main menu and toolbar if Dynamsoft SAW for VSS Plug-in menu and shortcuts is enabled. The actions will be invoked on the current active editor or the current selection if there is no active editor.

The context menu option will vary depending on the status of the file. If an option isn't available, but it should be, always try to do a refresh and see what happens.

All errors within the plug-in can be viewed by clicking Window menu > Show View > Error Log or in the Eclipse log-file located at (your workspace)\.metadata\.log.

How to use the plug-in

1. Basic Functions

History Options

Allows you to specify the date range or user for filtering the file history.

History Of File

View

Displays the content of the file with the default editor.

Details

Displays the details of the selected history item of the file, including the version number, date, user, label, etc.

Get

Gets the file to your workspace.

Diff

You can compare the selected version of the file with the local copy in workspace, or to any other version of the file. To compare two different versions of a file, hold down the Ctrl key while selecting the two versions of interest. Then click the Diff button.

For more details about the basic functions of Dynamsoft SAW for VSS plug-in, please refer to the help file of Dynamsoft SAW for VSS.

2. View Status Messages

The Dynamsoft SAW for VSS Message window displays the status message of Dynamsoft SAW for VSS. To enable the window, select Window ->Show View -> Other -> Dynamsoft SAW for VSS.


3. Customizing Dynamsoft SAW for VSS plug-in

Dynamsoft SAW for VSS options can be found under Window -> Preferences -> Team -> Dynamsoft SAW for VSS Option.

For information on each item of Dynamsoft SAW for VSS plug-in options, please refer to the help file of Dynamsoft SAW for VSS.

4. Dynamsoft SAW for VSS Plugin menu and shortcuts

To enable Dynamsoft SAW for VSS plug-in menu and shortcuts, select Window -> Customize Perspective.

Shortcuts

 

Commands


5. Label Decorations

To enable status showing for each item in the project, select Window -> Preferences -> Workbench -> Label Decorations.













SourceSafe (VSS) Remote/Web/Internet Access | Software Configuration Management | SCM Solution
Software Configuration Management Online | Source/Version Control Online | Version/Source Control Software
Copyright @2011 Dynamsoft Corporation. All Rights Reserved.