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Visual SourceSafe (VSS) Remote Access Tool Recommended by Microsoft


Error message: Error connecting to <IP>: <PORT>



Symptoms

You may get the error when you try to connect to SourceAnywhere for VSS Server.

Cause

1.The SourceAnywhere for VSS service is not started.
2.Network is unavailable.
3.You are connecting to a wrong server IP or port.
4.Firewall blocks the SoruceAnywhere for VSS port/service.

Resolution

  1. Make sure you have installed SourceAnywhere for VSS Server.
    Please click here if you are not sure how to install SourceAnywhere for VSS Server.

    If you have it installed, then please make sure the service is started. You can go to Server Manager -> ServerInfo -> Service Control to start the service.

    If you are not able to start the service, please click here.


  2. Make sure the network connection between the SourceAnywhere for VSS Server and Client is OK.
     
  3. Make sure the Server IP and port you are connecting to is correct. Please check if the IP address and port number is listed in Server Manager -> ServerInfo -> General Settings.
     
  4. If you have a firewall configured on the Server or Client, please make sure the firewall does not block the port you specify in Server Manager -> ServerInfo -> General Settings.

    If SourceAnywhere for VSS Server is installed on a Windows XP SP2 or Windows Server 2003 SP1 machine, please check if Windows Firewall is enabled on this server machine. If yes, it is likely the Windows Firewall is blocking connections from SourceAnywhere for VSS Client. In this case, please add a Windows Firewall exception for SourceAnywhere for VSS Service.

    For SourceAnywhere for VSS 5 Professional Server, the default path of SourceAnywhere for VSS Service is "(system disk):\Program Files\DynamSoft\SourceAnywhere for VSS Professional Server\SAWVService.exe". For information on how to add a Windows Firewall exception, please click here.