Use Dynamic Web TWAIN with Chrome 57

Google has just released Chrome 57 which officially stopped the support for SHA-1 certificates.

For users of Dynamic Web TWAIN (DWT) – the browser-based TWAIN scanning SDK:

  • If you are using the latest version – Dynamic Web TWAIN v12.2, please rest assured that it works fine with the latest version of Chrome.
  • If you are using DWT v12.1 or below, users might encounter issues when visiting your scan page that uses DWT. We recommend you upgrade to v12.2 which uses SHA-256 and works well with Chrome 57.

How to Upgrade to DWT v12.2 with SHA-256 Support

If you own a v12.x license or valid maintenance contract, you can get a free upgrade. Please contact sales@dynamsoft.com for the latest full version. Otherwise, you can purchase an upgrade.

How to upgrade to DWT 12.2 >

Meanwhile, there is a temporary solution to continue using the old versions of DWT with Chrome 57, read the KB article to learn more.

Let us know if you have any questions on using Dynamic Web TWAIN with Chrome 57.

Subscribe Newsletter

Subscribe to our mailing list to get the monthly update.

Subscribename@email.com