online source control
back to content
sign up free version control plan

Show Differences (Tools Menu)

See Also

Compares two items and shows the differences if any.

This command may be performed at the file level and project level. You can use Show Differences command to compare a file/project to any of their own versions or others in a local or server path. In Dynamsoft SAW Hosted, you can also perform a History Diff or Label Diff to compare two earlier versions of items to each other.

For file diff, Dynamsoft SAW Hosted visually displays the differences between two mergeable files but only can identify the differences between binary files.

Dynamsoft SAW Hosted may be configured with an external application for visual diff on files. This setting is in Tools->Options->External Programs tab. The default diff utility in Dynamsoft SAW Hosted is MergeHero.

For project diff, Dynamsoft SAW Hosted visually displays the differences in the Project Difference dialog box.

How to show file or project differences:

    1. Select a file in the file list or select a project in the project tree.

    2. Click the Files/Project Difference button on the toolbar or select Show Differences from either the Tools menu or by right-clicking the selected file or project.

    3. The Show Differences dialog box will be displayed. In this way, displays the differences between the local copy of the file or project and a version specified in Show Differences dialog box.

Or (History Diff)

1. Select a file or project in the History Explorer dialog box.

2. Click Diff button.

3. The History Diff dialog box will be displayed. In this way, displays the differences between the selected version of file or project  and a version specified in History Diff dialog box.

Or (Label Diff)

1. Select an item in the Show Labels dialog box.

2. Select Diff from either the Action menu or by right-clicking the item associated with the selected label.

3. The Label Diff dialog box will be displayed. In this way, displays the differences between the version of file or project associated with the selected label and a version specified in Label Diff dialog box..