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Error Troubleshooting

Error Message - Failed to load resource: net::ERR_CERT_DATE_INVALID

Symptom

You get an error message that says “Failed to load resource: net::ERR_CERT_DATE_INVALID https://local.dynamsoft.com:18623/f/VersionInfo?ts=XXXXXXXXXXXX”. And the browser keeps asking to install the Dynamsoft Service.

Cause

By default, “127.0.0.1” is used for service connection. “127.0.0.1” uses a self-signed certificate because it is an internal IP address, if your environment requires high level security, self-signed certificates may not be accepted. Moreover, Android OS or Chrome OS does not accept connection between browsers and Dynamsoft Service via “127.0.0.1”.

In the case that you have used our expired certificate - local.dynamsoft.com, you will need to update to the latest VeriSign’ed certificate. The most recent expired “local.dynamsoft.com” certificate expired on January 9th, 2023 and the latest certificate will expire on December 8th, 2023

Please note: all official certificates issued by 3rd party come with an expiry date - generally one year. This means that each year the certificate will need to be updated if local.dynamsoft.com is used.

Resolution

  • No High Level Security Requirement: Set back to self-signed certificate “127.0.0.1” by comment the line Dynamsoft.WebTwainEnv.Host = "local.dynamsoft.com" or Dynamsoft.DWT.Host="local.dynamsoft.com" out. No need to worry about the expiry date of the certificate anymore.

  • High Level Security Requirement (Please note: you need to replace the certificate annually due to expiration)

    1. (Recommended) Revert back to the self-signed certificate for “127.0.0.1”. Dynamsoft understands the importance of information security and are committed to remaining one of the most security-compliant companies in the industry. Starting from April 9,2021, Dynamsoft becomes ISO 27001 certified. Although a self-sign certificate is being used all connections are limited to the device itself (127.0.0.1) which ensures security in most cases.

    2. If you have to use “local.dynamsoft.com”, the following methods can be taken:

      • Method 1 (Recommended). Take advantage of the new feature – Remote Scan which released in v18.0. With Remote Scan, you can limit the number of Dynamsoft Service Installations to a minimum. For more details, please refer to What is Remote Scan.

      • Method 2. If you must fix the issue on a few client machines immediately, manually update the following cert files on the client-side machine. Click here to download the new certificate and use the new server.pem.ldsc & server_key.pem.ldsc to replace the old one under C:\Windows\SysWOW64\Dynamsoft\DynamsoftService(DynamsoftServicex64)\cert. Then restart Dynamsoft Service.

        Note: the new certificate from Dynamsoft will expire on December 8th, 2023. This means you must update the certificate again after this certificate expires.

      • Method 3. Contact Dynamsoft for a new MSI for client-side. Please specify the exact service version build number found from the version your client currently has installed.

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